This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: vim-8.0.1376-1: Possible bug with ruby extensions

On 2018-02-06 09:37, Ameya Vikram Singh wrote:
> Maintainers of the ViM/GViM text editor.
> I am noticing that currently with the latest build of ViM
> editor(vim-8.0.1376-1),
> I am unable to use the command-t [1] plugin with this release.
> When invoking the functionality with the key combination: `\` + `t`
> I get the following error message on the ViM editor:
>     command-t.vim requires Vim to be compiled with Ruby support
>     For more information type:   :help command-t
> When checking the vim feature from the bash terminal using:
>     vim --version
> I do see in the output `+ruby/dyn`, which means that ruby support
> should be enabled.
> When checking for ruby compatibility with ViM using the following in
> command mode:
>     :ruby puts RUBY_VERSION
> One gets the following error message:
>     E448: Could not load library function rb_assoc_new
>     E266: Sorry, this command is disabled, the Ruby library could not be loaded.
>     Press ENTER or type command to continue
> I will try to rebuild the from the sources (vim-8.0.1376-1-src) and
> see if the error persists.

You need to install the ruby package to provide the dynamic library for support.

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]