This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

setup-x86_64.exe v2.889 doesn't select additionally downloaded packages when installing from local directory

Summary of problem:
When installing Cygwin from a local directory, setup-x86_64.exe version 2.889 doesn't
list the packages that I additionally selected for download when previously downloading
to that directory, and the top line of the GUI under Category view says "No packages found<->Default".
Continuing the install only installs the packages preselected by setup.

To install a fresh version of Cygwin, I usually do this: Run setup-x86_64.exe
using "Download Without Installing", select some additional packages, and then after
everything finished, I rerun setup-x86_64.exe using "Install from Local Directory",  and then
the GUI, under Category view, shows "All <-> Default", beneath which is a hierarchical
list including the packages preselected by setup along with the additional ones that I selected
when downloading.

Here's the problem: I performed the above process using today's version of setup-x86_64.exe
from, which according to setup.ini is setup version 2.889, and the
"Download Without Installing" setup worked as expected. However, when I next
did "Install from Local Directory" using that directory, instead of showing "All<->Default", it
showed "No packages found<->Default", and only the packages preselected by
setup were not going to be skipped. I tried changing "Default" to "Install" at the
top level of the list, but that then selected everything for install, not just the preselected
packages and the additional ones I had downloaded. I repeated this process using
a few different mirror sites for the download phase, but that made no difference.

Interestingly, if I copy an older version of setup-x86_64.exe into my already-downloaded
directory, e.g. setup-x86_64.exe version 2.880, the GUI is able to find the selected packages
that I had already downloaded using setup version 2.889, after of course giving a few warnings
about the current ini file being from a newer version of setup. In other words, if I download
using setup v2.889, then when subsequently installing from that directory, setup v2.889 doesn't
know what additional packages I had selected, whereas setup v2.880 does know.

I'm wondering if I'm not doing something correctly, or if there is an issue with version 2.889 of
setup-x86_64.exe not finding packages that were additionally selected for download.

Version details:
The  beginning of setup.ini in my download directory includes this:
release: cygwin
arch: x86_64
setup-timestamp: 1519974241
setup-version: 2.889

This was done on Windows 10 pro, using  setup-x86_64.exe v2.889 downloaded
on March 3, 2018 UTC from, which currently indicates that the most recent
version of the Cygwin DLL is 2.10.0.

Thanks in advance for any help.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]