This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: setup-x86_64.exe v2.889 doesn't select additionally downloaded packages when installing from local directory

On 2018-03-03 21:01, Robert Cohen wrote:
>> On March 3, 2018 22:11, Ken Brown wrote:
>> On 3/3/2018 10:01 PM, Robert Cohen wrote:
>>>    Thanks for finding that. However, I am using the same "Local Package Directory" that I used
>>> when I ran it to do the download. For example, here's where things were for all the steps:
>>> 1. Directory C:\Updates\cygwin_download, containing setup-x86_64.exe and nothing else
>>> 2. Ran setup, "Download without installing", specifying C:\Updates\cygwin_download as
>>>        the local package directory, then selected additional packages and performed the download.
>>> at this point, C:\Updates\cygwin_download contained setup-x86_64.exe and a
>>> subdirectory for the mirror site. The setup.ini file was in a x64_64 subdirectory
>>> under the mirror site subdirectory.
>>> 3. Then I ran setup again, "Install from local directory", with C:\cygwin64 as the root directory
>>>        and C:\Updates\cygwin_download as the local package directory.
>>> Should I have specified something differently for it to detect the additional packages that I
>>> selected for download? I looked in setup.ini and it does list the additional packages that
>>> I had selected.
>> No.  Based on what you said, I don't know what the problem was.  Does 
>> /var/log/setup.log.full give any clues?

> I checked the log file, and it appears to have found the .ini file, and then 
> it ran a solver. Here's a portion of setup.log.full:
> ...
> 2018/03/03 22:13:47 Selected local directory: C:\Updates\cygwin_download
> Found ini file - C:\Updates\cygwin_download/
> .ini setup_version is 2.889, our setup_version is 2.889
> 2018/03/03 22:13:49 io_stream_cygfile: fopen(/etc/setup/installed.db) failed 2 No such file or directory
> 2018/03/03 22:14:16 solving: 36 tasks, update: yes, use test packages: no
> libsolv: solver started
> ...
> Later it said "libsolv: 69 installed packages:", which appeared just to be the default preselected packages.
> The log mentions nothing about my additionally selected packages.
> I also looked at the logfile on another computer which used the older setup 2.880. In that log,
> after finding the .ini file, it added some dependencies and checked the SHA512 for some files,
> and those files included the extra ones that I had selected. The 2.880 setup file had no messages from
> libsolver.
> One other difference I noticed was right at the beginning of the logfiles:
> 2018/03/03 22:13:12 Starting cygwin install, version 2.889
> 2018/03/03 22:13:12 User has backup/restore rights
> 2018/03/03 22:13:12 Current Directory: C:\Updates\cygwin_download\\x86_64
> vs.
> 2017/06/20 18:42:33 Starting cygwin install, version 2.880
> 2017/06/20 18:42:33 User has backup/restore rights
> 2017/06/20 18:42:33 Current Directory: E:\Updates\cygwin_install
> In both cases, I ran the setup executable from C:\Updates\cygwin_download, yet the "Current Directory"
> reported by the logfiles differ. 
> Could the problem be related to the difference in "Current Directory", or perhaps related to the solver 
> or to whatever in the new setup program parses the setup.ini file once it's found?

Could you please provide the complete 2.889 setup.log.full as a text attachment
for inspection? That may allow us to see if it found all your cached packages,
and did not use them, or skipped them.

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]