This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: getent doesn't work properly

Hello again,

Unfortunately the problem returned :(
For the same server and now an additional one.
This time removing from the domain and deleting the entries did not do the trick, maybe if I delete from all DC servers instead waiting for replication it might help, but since the issue started again this is not a final solution anyway.

There is AV software installed on any of these servers.

Feel free to send me the additional info you mentioned.

Thanks a lot for the help!
Much appreciated!

-----Original Message-----
From: Maayan Apelboim [] 
Sent: Monday, October 28, 2019 10:57 AM
Subject: RE: getent doesn't work properly

Thanks.  What happens is that in the non-working scenario the user name is refused by Cygwin because it's apparently not in the primary domain of the machine.  I.e., if the machine's primary domain is "dom0", and "user1" is in "dom1", then the account has to be called "dom1+user1".  The name only is forbidden in this case.

However, this doesn't explain why this happens at all since apparently "user1" is in the primary domain of the machine, and why it only fails intermittendly.  In both cases, working and non-working, the domain is returned by the same Windows call LookupAccountNameW.

What's really strange is that in the working case a lot of network related Windows DLLs are loaded into the process, e.g. wshqos.dll, WSHTCPIP.DLL, wship6.dll etc., while this does not happen in the non-working case.  None of these DLLs is requested by Cygwin, so this is something occuring in the native Windows background.  This is a bit suspicious and may point to some interaction with a virus scanner or something along these lines, and which for some reason doesn't always work as desired (Avast, anybody?)  Can you check this, perhaps?

Apart from that first question is, is the domain really called "dom"
and is the user account name really "user1"?  I'm asking because the name may collide with another account name from a builtin or second domain, and sometimes the wrong user account is returned by the Windows functions for whatever reason.

Second question is, can I send you the URL to a Cygwin test DLL with extended debug info in private email?  In this case I'd only need the non-working trace, preferredly verbatim, and you can return the trace by private email as well.


Corinna Vinschen
Cygwin Maintainer


After reading your email I started to suspect having a domain issue.
I removed the server from the domain, deleted all its relevant records and rejoined it.
It seems the problem was solved for now.
I already tried in the past removing it from the domain, and even reinstalled the server, but it didn't help, I think deleting all corresponding records after removing from domain did the trick.

I will update if this issue re-occurs.

I really appreciate the help!


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]