This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [DOC PATCH] Re: [PATCH]*3 Re: [RFC] "info powerpc"

> From: Paul Gilliam <>
> Date: Thu, 15 Sep 2005 12:06:19 -0700
> Cc:
> The "info powerpc" group of commands (all none of them) are not documented.

As you point out, "info powerpc" was until now a prefix with no
commands, that's why it is undocumented (or, rather, all zero of these
commands are documented ;-).

> If we decide to just get rid of it, then no user manual changes are needed.

Right; but your favorite alternative was to keep it.

> If we decide to keep it and make 'info powerpc altivec' an alias for "info vector", then we can use the attached doc patch.

Thanks; see a couple of comments below.

> Index: gdb.texinfo
> ===================================================================
> RCS file: /cvs/src/src/gdb/doc/gdb.texinfo,v
> retrieving revision 1.278
> diff -a -u -r1.278 gdb.texinfo
> --- gdb.texinfo	27 Aug 2005 12:51:28 -0000	1.278
> +++ gdb.texinfo	15 Sep 2005 18:27:23 -0000
> @@ -4991,6 +4991,7 @@
>  * Registers::                   Registers
>  * Floating Point Hardware::     Floating point hardware
>  * Vector Unit::                 Vector Unit
> +* PowerPC Features::            PowerPC hardware features

I don't think this is a good place for this section.  There's already
a section on PowerPC-specific features, so we should add this
information there, I think.

> +@node PowerPC Features
> +@section PowerPC Features
> +@cindex PowerPC Features
> +
> +Some PowerPC chips have features that are in addition to the core functionality
> +of the architecture.  Depending on the configuration, @value{GDBN} may be able
> +to give you information about the status of those features.
> +
> +@table @code
> +@kindex info powerpc altivec
> +@item info powerpc altivec
> +Display information about the Altivec unit.  This will consist of the contents
> +of the Altivec registers @code(vr0) through @code(vr31), along with that of the
> +@code(vrsave) and @code(vsrc) registers.
> +@end table
> +

I think this text should have a cross-reference to the "Vector Unit"
node, since the new command essentially does the same job, right?

Finally, we need a ChangeLog entry for this change.

Other than that, this patch for the manual is approved, assuming that
the code patches are also approved.  Thanks.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]