This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA] Resubmit reverse debugging [5/5]


What about adding "previous" and either "pr" or "pre" as alias to
reverse-next? Sounds more natural to me than "reverse-next". Similarly,
"previousi" and "pri" or "prei".

I'd also half-seriously suggest adding a "step-back" alias on the same
grounds. :-)

Lots of people have alternate suggestions for command names. The present set is as close to convergence as we were able to get in several previous rounds of discussion.

I don't want the feature to be held up by this discussion,
so I'm just saying "aliases are easy to add later".

I would like to continue the discussion about alias name for the too long reverse commands. I am not sure that the gdb-patches list is the right place for having this discussion.

My new command alias suggestions are in the right column:
reverse-continue - reverse
reverse-finish   - uncall
reverse-next     - previous, prev
reverse-nexti    - previousi, previ
reverse-step     - unstep
reverse-stepi    - unstepi

The main reasons for the new alias names is to better describe what
the commands actually do and distinguish them from the "forward"
debugging commands. The reverse- commands implies that running a
program in reverse is only a special mode of running it forward. This
is no longer true and the support for running in reverse will increase
in the future.

/Tomas Holmberg


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]