This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA] Add la_getstr member to language_defn


> The patch doesn't apply anymore. This is the same patch, refreshed
> against HEAD as of Dec 28th. Ok?

Just a few comments and questions in addition to Tom's comments...

> +      if ((TYPE_NFIELDS (type) == 1)
> +	  && TYPE_CODE (TYPE_FIELD_TYPE (type, 0)) == TYPE_CODE_RANGE)

The extra parens around "TYPE_NFIELDS (type) == 1" shouldn't be
necessary, right? In this case, it's pretty harmless, but a little
bit below, this really starts making it hard to read a condition...

> +  if (((VALUE_LVAL (value) == not_lval)
> +      || (VALUE_LVAL (value) == lval_internalvar)) && (fetchlimit != UINT_MAX))

Can this be formatted as follow:

  if ((VALUE_LVAL (value) == not_lval
       || VALUE_LVAL (value) == lval_internalvar)
      && fetchlimit != UINT_MAX)

? (assuming my reading is correct!) The reason I like my suggestion
is because there are less parentheses, so it's easier to match them
without using my favorite editor; also, the formatting makes it clear
at which level the || and the && operators are.

> +  if ((TYPE_CODE (element_type) != TYPE_CODE_INT)
> +      && (TYPE_CODE (element_type) != TYPE_CODE_CHAR))

Same here.

> @@ -511,6 +626,7 @@ const struct language_defn minimal_language_defn =
>    c_language_arch_info,
>    default_print_array_index,
>    default_pass_by_reference,
> +  default_get_string,
>    LANG_MAGIC
>  };

I was wondering if it wouldn't be more useful to use the c_get_string
function as the default rather than the default_get_string stub.
What do you guys think? Granted, I know that there are cases for Ada
where this isn't going to be enough, but I also know that it's going
to handle some cases fine. I don't know how other languages such as
Fortran or Pascal encode their strings, but chances are that if we
call this function with a value whose type is an array of chars/ints
or a char/int pointer, the c_get_string value would probably work.

As for the Ada implementation, it's probably going to look like this:

  if (value_type is char/int_array or char/int_pointer)
    {
      /* A string a-la-C: Call the C get_string routine...  */
      c_get_string (...);
      return;
    }

  /* Ada-specific strings handled here.  */

So setting the la_get_string method to c_get_string would be a good
starting point for Ada.  The implementation is robust enough that
we'd get an error if the value type is not handled properly, which
is exactly what the default_get_string routine always does.

-- 
Joel


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]