This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch] Rename process_next_line variables


On Fri, 01 Jan 2010 09:43:32 +0100, Jan Kratochvil wrote:
2010-01-01  Jan Kratochvil  <jan.kratochvil@redhat.com>

	* cli/cli-script.c (process_next_line): Rename p1 as p_end and p2 as
	p_start.  Change != comparisons to > and < comparisons.

Updated the ChangeLog entry.


Sorry,
Jan


> -  while (p1 != p && (p1[-1] == ' ' || p1[-1] == '\t'))
> +  while (p_end > p && (p_end[-1] == ' ' || p_end[-1] == '\t'))

> -  while (p2 != p1 && (*p2 == ' ' || *p2 == '\t'))
> +  while (p_start < p_end && (*p_start == ' ' || *p_start == '\t'))


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]