This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch] value_change_enclosing_type -> set_value_enclosing_type


> This patch does two things:
> - rename value_change_enclosing_type to set_value_enclosing_type,
>   and make the result void, for clarity and consistency with other
>   set_value_foo functions
> - have value_full_object always return a new value if it needs to
>   modify the input value
> 
> I will check it in in a few days if there are no objections.
> 
> Tested on amd64-linux, no regressions.
> 
> 2010-11-06  Doug Evans  <dje@google.com>
> 
> 	* value.c (set_value_enclosing_type): Renamed from
> 	value_change_enclosing_type.  All callers updated.
> 	* value.h (set_value_enclosing_type): Update.
> 	* valops.c (value_full_object): Always return a copy if we need to
> 	make changes to the input value.

FWIW, I like this change.

-- 
Joel


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]