This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFC][PATCH] Allow JIT unwinder provide symbol information


On Tue, Jan 14, 2014 at 4:39 PM, Alexander Smundak <asmundak@google.com> wrote:
> I fixed the patch based on your comments, except for the one
> about using LWP for thread identification.
> Waiting for the opinions about the approach used in this RFC patch.
>
>>  > +/* Returns LWP ID of the current thread or 0.  */
>>  > +
>>  > +typedef long (gdb_get_lwp) (void);
>>
>> The term "lwp" might be an insufficiently portable concept that we either
>> need to pick a different name or use a different value here.
>> It may be sufficient to stick with "lwp" but add further comments
>> specifying how it's used so that one can translate it to whatever else
>> is used on a non-lwp-using host.
>> Alas I don't have a good answer.  Hopefully someone else here does.
> ...
>>  > +long
>>  > +jit_get_current_lwp (void)
>>  > +{
>>  > +  long lwp = ptid_get_lwp (inferior_ptid);
>>  > +
>>  > +  // ptid_get_lwp returns 0 in the remote debugging case. Try getting
>>  > +  // thread id then.
>>  > +  // TODO(asmundak): perhaps use thread id always?
>>  > +  return lwp ? lwp : ptid_get_tid (inferior_ptid);
>>  > +}
>>
>> In what situation does ptid_get_lwp return 0 for remote debugging?
> If inferior is run by the gdbserver, I see that inferior.ptid.lwp
> is 0, while inferior_ptid.tid is LWP. If inferior runs locally, it's
> the opposite:inferior_ptid.lwp is LWP while inferior_ptid.tid is 0.

Ah, righto.  Blech.

>> Also, getting back to whether "lwp" is sufficient portable,
>> how does the external code use the value?
> JVM maintains its own list of threads, using LWP as thread's unique
> identifier.Java frame unwinder code checks that the frame belongs to
> the thread it knows about.

This feels like a case where a level of indirection is sufficient, the
only hard part is picking a good name.
IOW, if we replaced "lwp" with "jti" [Jit Thread Id] then I think
that'd be sufficient (or even "jtid").
Java folks can even pretend the J is for Java and not Jit. :-)
As for whether jti{,d} is a reasonable name ... dunno.

If other's don't chime in within a week I'm going to make a Command
Decision :-) and say let's go with that.
And I'm happy to pick a different name.  I just feel uncomfortable
with using "lwp" since in the remote case while it is the lwp it comes
from ptid.tid, and other systems may not use the term "lwp".
I'm willing to be persuaded that using "lwp" here is just fine though.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]