This is the mail archive of the gdb@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [rfc] ``pc'' -> resume_addr?


> Hello,
> 
> GDB, in a number of places, refers to the ``pc'' - PC_REGNUM, frame->pc,  read_pc(), write_pc(), ...
> 
> I think this name choice was unfortunate.  It is too easy for a developer to confuse ``pc'' with the hardware ``pc''.
> 
> With this in mind, I'd like to propose a GDBspeak ``resume_addr''.  It is the address of the first instruction that will be executed when the target resumes.
> 
> thoughts?  better names?
> Andrew 

To follow this up.  My take on this is:

The real culprit is DECR_PC_AFTER_BREAK.  That needs to be eliminated. 
If that goes, much of the PC confusion will go with it.  Me trying to 
rename ->pc is like applying window dressing :-)

Secondary to this, there is read_pc() vs PC_REGNUM. (At the risk of 
starting another debate :-) Perhaphs, I should rename PC_REGNUM to 
HW_PC_REGNUM (same for FP and SP and PSW). That way it is clear that 
these regnum's can only map onto hardware registers.

enjoy,
Andrew


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]