This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] simplify ulimit implementation


Alle lunedì 19 novembre 2012, Roland McGrath ha scritto:
> sysdeps/posix is appropriate because it's implemented in terms of
> POSIX interfaces.

OK.

> It's bad to lose any functionality, though __UL_GETMAXBRK actually
> being used seems a bit unlikely.  But it's easy enough to add it. 

Please note that in the linux implementation that case has not bee 
implemented on purpose: in d2f5be2a1235061b46c51d7530264d086eca46ef that 
implementation was copied from the bsd one, and the case for 3 
(__UL_GETMAXBRK) removed (with the comment adjusted).

If __UL_GETMAXBRK is really wanted, I could propose to implement it in 
the new posix version, but surrounded within a #ifndef 
ULIMIT_SKIP___UL_GETMAXBRK (or better names welcome), and then replace 
the whole linux implementation with:
#define ULIMIT_SKIP___UL_GETMAXBRK
#include <sysdeps/posix/ulimit.c>
(my initial idea was something close to the way e.g. the linux sysconf 
implementation "overrides" the posix one, but the fact that ulimit takes 
varargs complicates that approach a bit.)

> So I'd do: First commit: move file verbatim to sysdeps/posix/.
> Second commit: add __UL_GETMAXBRK to that implementation.
> Third commit: remove sysdeps/unix/bsd/ file.

OK, I will split the commits once approved.

-- 
Pino Toscano

Attachment: signature.asc
Description: This is a digitally signed message part.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]