This is the mail archive of the pthreads-win32@sources.redhat.com mailing list for the pthreas-win32 project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: catch (...)



> #define PtW32CatchAll \
>         catch( ptw32_exception & ) { throw; } \
>         catch( ... )

Seems like it might be more appropriate (possibly required by the pthread
standard?) for this to have a prefix of "pthread_" and a suffix of "_np" for
non-portable; potentially "pthread_w32_catch_all_np" or similar instead of
"PtW32CatchAll" ?  The same holds true for other PtW32 prefixed items.  It
seems wrong to introduce another namespace.

Dave


__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]