This is the mail archive of the
mailing list for the systemtap project.
[Bug translator/10830] new pp() variant for source-level probe point name
- From: "przemyslaw at pawelczyk dot it" <sourceware-bugzilla at sourceware dot org>
- To: systemtap at sources dot redhat dot com
- Date: 23 Jun 2010 10:22:23 -0000
- Subject: [Bug translator/10830] new pp() variant for source-level probe point name
- References: <email@example.com>
- Reply-to: sourceware-bugzilla at sourceware dot org
------- Additional Comments From przemyslaw at pawelczyk dot it 2010-06-23 10:22 -------
(In reply to comment #3)
> pp1() is pretty obscure.
> What about pn() for probe-name (where pp() is for probe-point)?
Sound better than "pretty please" or "people", but can be misleading.
After all the name of the probe alias is returned here.
I suggest following renames:
pp() -> ppname()
ppl() -> paname()
and leaving pp() as (deprecated) alias for new name (backward compatibility or
maybe only via --compatible).
Yes, new names would be more verbose, but also more clean IMHO. What do you
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.