epiphany 3.8.2
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>
Sun, 13 Jul 2014 17:00:03 +0000 (12:00 -0500)
committerYaakov Selkowitz <yselkowitz@users.sourceforge.net>
Sun, 13 Jul 2014 17:00:03 +0000 (12:00 -0500)
2.30-implib.patch [deleted file]
3.4.1-introspection.patch [deleted file]
3.8.2-webkit1.patch [new file with mode: 0644]
epiphany.cygport

diff --git a/2.30-implib.patch b/2.30-implib.patch
deleted file mode 100644 (file)
index 95a016b..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
---- origsrc/epiphany-2.30.2/configure.ac       2010-04-08 09:55:44.000000000 -0500
-+++ src/epiphany-2.30.2/configure.ac   2010-06-28 03:23:08.182638400 -0500
-@@ -366,6 +366,19 @@ AM_CONDITIONAL([ENABLE_NETWORK_MANAGER],
- # uninstalled share dir to search data
- AC_DEFINE_UNQUOTED([SHARE_UNINSTALLED_DIR], ["`pwd`/data"], [path to source data dir])
-+case "$host_os" in
-+      cygwin*)
-+              platform_win32=yes
-+              EPHY_IMPLIB="-lepiphany-$EPIPHANY_API_VERSION"
-+              ;;
-+      *)
-+              platform_win32=no
-+              EPHY_IMPLIB=
-+              ;;
-+esac
-+AC_SUBST(EPHY_IMPLIB)
-+AM_CONDITIONAL(PLATFORM_WIN32, test "$platform_win32" = "yes")
-+
- # *******************************
- # Add warning flags
- # *******************************
---- origsrc/epiphany-2.30.2/data/epiphany.pc.in        2010-04-08 09:09:30.000000000 -0500
-+++ src/epiphany-2.30.2/data/epiphany.pc.in    2010-06-28 03:23:08.189638800 -0500
-@@ -13,5 +13,5 @@ Name: Epiphany Browser
- Description: GNOME Web Browser
- Version: @VERSION@
- Requires: gtk+-3.0, libxml-2.0, webkitgtk-3.0
--Libs: -L${libdir}
-+Libs: -L${libdir} @EPHY_IMPLIB@
- Cflags: -I${includedir}
---- origsrc/epiphany-2.30.2/src/Makefile.am    2010-04-08 09:09:41.000000000 -0500
-+++ src/epiphany-2.30.2/src/Makefile.am        2010-06-28 03:23:41.821562500 -0500
-@@ -157,6 +157,10 @@ epiphany_CFLAGS = \
- epiphany_LDFLAGS = -dlopen self
-+if PLATFORM_WIN32
-+epiphany_LDFLAGS += -Wl,--out-implib,libepiphany-$(EPIPHANY_API_VERSION).dll.a
-+endif
-+
- epiphany_LDADD = \
-       libephymain.la \
-       $(top_builddir)/src/bookmarks/libephybookmarks.la \
-@@ -368,3 +372,9 @@ Epiphany-$(EPIPHANY_API_VERSION).typelib
- endif # HAVE_INTROSPECTION
- endif # !WITH_WEBKIT2
-+
-+if PLATFORM_WIN32
-+install-data-local:
-+      $(mkinstalldirs) $(DESTDIR)$(libdir)
-+      $(INSTALL_DATA) libepiphany-$(EPIPHANY_API_VERSION).dll.a $(DESTDIR)$(libdir)
-+endif
diff --git a/3.4.1-introspection.patch b/3.4.1-introspection.patch
deleted file mode 100644 (file)
index 9be3c44..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- origsrc/epiphany-3.4.1/src/Makefile.am     2012-05-14 20:46:42.532657600 -0500
-+++ src/epiphany-3.4.1/src/Makefile.am 2012-05-14 20:47:57.375938400 -0500
-@@ -278,7 +278,7 @@ EPHY_GIR_C_FILES = \
-       $(NULL)
- Epiphany-$(EPIPHANY_API_VERSION).gir: $(INTROSPECTION_SCANNER) $(EPHY_GIR_H_FILES) \
--                                      $(EPHY_GIR_C_FILES) epiphany
-+                                      $(EPHY_GIR_C_FILES) epiphany$(EXEEXT)
-       $(AM_V_GEN) PKG_CONFIG_PATH=$(top_builddir)/data:$$PKG_CONFIG_PATH \
-       $(INTROSPECTION_SCANNER) -v --warn-all \
-               --identifier-prefix=Ephy \
-@@ -290,7 +290,7 @@ Epiphany-$(EPIPHANY_API_VERSION).gir: $(
-               --include=Gtk-3.0 \
-               --include=libxml2-2.0 \
-               --include=WebKit-3.0 \
--              --program=./epiphany \
-+              --program=./epiphany$(EXEEXT) \
-               --output=$@ \
-               --pkg=epiphany-$(EPIPHANY_API_VERSION) \
-               -DEPIPHANY_COMPILATION \
diff --git a/3.8.2-webkit1.patch b/3.8.2-webkit1.patch
new file mode 100644 (file)
index 0000000..90cca94
--- /dev/null
@@ -0,0 +1,11 @@
+--- origsrc/epiphany-3.8.2/configure.ac        2013-05-31 05:28:55.000000000 -0500
++++ src/epiphany-3.8.2/configure.ac    2014-07-13 03:22:08.596596600 -0500
+@@ -90,7 +90,7 @@ GCR_REQUIRED=3.5.5
+ AVAHI_REQUIRED=0.6.22
+ # Set to 'no' to build with the WebKit1 backend
+-with_webkit2=yes
++with_webkit2=no
+ if test "x$with_webkit2" != xno; then
+    WEBKIT_GTK_PC_NAME=webkit2gtk-3.0
index 71306a0e04e30040d5a45a6e625c30649fc54038..f5f223027d20d4b5c7531a0760cc9271610b56c9 100644 (file)
@@ -1,30 +1,22 @@
 inherit gnome2
 
 NAME="epiphany"
-VERSION=3.6.1
-RELEASE=3
+VERSION=3.8.2
+RELEASE=1
 CATEGORY="GNOME Web"
 SUMMARY="GNOME web browser"
 DESCRIPTION="Epiphany is the web browser for the GNOME desktop. Its goal is
 to be simple and easy to use. Epiphany ties together many GNOME components in
 order to let you focus on the Web content, instead of the browser application."
 
-PATCH_URI="
-       2.30-implib.patch
-       3.4.1-introspection.patch
-"
+PATCH_URI="3.8.2-webkit1.patch"
 
-PKG_NAMES="${PN} ${PN}-devel"
-epiphany_REQUIRES="ca-certificates iso-codes"
-epiphany_CONTENTS="--exclude=aclocal --exclude=gir-1.0 --exclude=gtk-doc
-                   etc/ usr/bin/ usr/share/"
-epiphany_devel_SUMMARY="${SUMMARY} (plugin development)"
-epiphany_devel_CONTENTS="usr/include/ usr/lib/lib* usr/lib/pkgconfig usr/share/aclocal/
-                         usr/share/gtk-doc/"
+REQUIRES="ca-certificates iso-codes"
+# adblock merged with core; extensions are no longer supported
+OBSOLETES="epiphany-devel epiphany-extensions"
 
-# introspection: only need for Seed-based plugins (currently nonexistant)
+# nss: only used for migrating from Mozilla profiles
 CYGCONF_ARGS="
-       --disable-introspection
        --disable-network-manager
        --disable-nss
        --with-ca-file=/usr/ssl/certs/ca-bundle.crt
This page took 0.024874 seconds and 5 git commands to generate.