Version bump, built with cygport.
authoryselkowitz <yselkowitz@e127d73d-b18e-4ae1-a744-a22e6a3ccd30>
Sun, 12 Nov 2006 04:56:09 +0000 (04:56 +0000)
committeryselkowitz <yselkowitz@e127d73d-b18e-4ae1-a744-a22e6a3ccd30>
Sun, 12 Nov 2006 04:56:09 +0000 (04:56 +0000)
git-svn-id: https://cygwin-ports.svn.sourceforge.net/svnroot/cygwin-ports/ports/trunk@503 e127d73d-b18e-4ae1-a744-a22e6a3ccd30

README
devel.hint [new file with mode: 0644]
setup.hint

diff --git a/README b/README
index 368e89f2c2ab1631f7182b951a55b8ff3ec91b23..ccdf8b4950cad04cffe0c5e93b2ded7bb3121891 100644 (file)
--- a/README
+++ b/README
@@ -7,21 +7,22 @@ GPGME provides a high-level crypto API for encryption, decryption,
 signing, signature verification and key management.
 
 Runtime requirements:
-  cygwin-1.5.19-4
-  gnupg-1.4.2.1-1
+  cygwin-1.5.21-2
+  gnupg-1.4.5-1
   libgpg-error-1.1-1
 
 Build requirements:
 (besides corresponding -devel packages)
-  cygwin-1.5.19-4
-  autoconf2.5-2.59-3
+  cygwin-1.5.21-2
+  autoconf2.5-2.60-1
   automake1.9-1.9.6-1
-  binutils-20050610-1
+  binutils-20060817-1
+  cygport-0.2.6-1
   gawk-3.1.5-2
   gcc-core-3.4.4-1
-  libtool1.5-1.5.20-2
-  make-3.80-1
-  sed-4.1.3-1
+  libtool1.5-1.5.23a-1
+  make-3.81-1
+  sed-4.1.5-1
 
 Canonical homepage:
   http://www.gnupg.org/(en)/related_software/gpgme/
@@ -36,18 +37,36 @@ Build instructions:
     if you use setup to install this src package, it will be
         unpacked under /usr/src automatically
   cd /usr/src
-  ./gpgme-1.0.3-1.sh all
+  cygport ./gpgme-1.0.3-1.cygport all
 
 This will create:
   /usr/src/gpgme-1.0.3-1-src.tar.bz2
   /usr/src/gpgme-1.0.3-1.tar.bz2
+  /usr/src/libgpgme-devel-1.0.3-1.tar.bz2
   /usr/src/libgpgme11-1.0.3-1.tar.bz2
 
 -------------------------------------------
 
-Files included in the binary package:
+Files included in the binary packages:
 
+(gpgme)
   /etc/postinstall/gpgme.sh
+  /usr/share/doc/Cygwin/gpgme-1.1.2.README
+  /usr/share/doc/gpgme-1.1.2/AUTHORS
+  /usr/share/doc/gpgme-1.1.2/COPYING
+  /usr/share/doc/gpgme-1.1.2/ChangeLog
+  /usr/share/doc/gpgme-1.1.2/INSTALL
+  /usr/share/doc/gpgme-1.1.2/NEWS
+  /usr/share/doc/gpgme-1.1.2/README
+  /usr/share/doc/gpgme-1.1.2/THANKS
+  /usr/share/doc/gpgme-1.1.2/TODO
+  /usr/share/info/gpgme.info.gz
+
+(libgpgme11)
+  /usr/bin/cyggpgme-11.dll
+  /usr/bin/cyggpgme-pthread-11.dll
+
+(libgpgme-devel)
   /usr/bin/gpgme-config
   /usr/include/gpgme-1.0/gpgme.h
   /usr/lib/libgpgme-pthread.dll.a
@@ -55,29 +74,16 @@ Files included in the binary package:
   /usr/lib/libgpgme.dll.a
   /usr/lib/libgpgme.la
   /usr/share/aclocal/gpgme.m4
-  /usr/share/doc/Cygwin/gpgme-1.0.3.README
-  /usr/share/doc/gpgme-1.0.3/AUTHORS
-  /usr/share/doc/gpgme-1.0.3/ChangeLog
-  /usr/share/doc/gpgme-1.0.3/COPYING
-  /usr/share/doc/gpgme-1.0.3/INSTALL
-  /usr/share/doc/gpgme-1.0.3/NEWS
-  /usr/share/doc/gpgme-1.0.3/README
-  /usr/share/doc/gpgme-1.0.3/THANKS
-  /usr/share/doc/gpgme-1.0.3/TODO
-  /usr/share/info/gpgme.info.gz
-
-Files included in the library package:
-
-  /usr/bin/cyggpgme-11.dll
-  /usr/bin/cyggpgme-pthread-11.dll
 
 ------------------
 
 Port Notes:
 
+----- version 1.1.2-1 -----
+Version bump.  Created separate development packages.
+
 ----- version 1.0.3-1 -----
-Version bump.
-Created separate library package.
+Version bump.  Created separate library package.
 
 ----- version 1.0.2-1 -----
 New upstream version.
diff --git a/devel.hint b/devel.hint
new file mode 100644 (file)
index 0000000..d10b709
--- /dev/null
@@ -0,0 +1,8 @@
+category: Libs
+requires: cygwin libgpg-error
+sdesc: "GnuPG cryptography support library (development)"
+ldesc: "GPGME  (GnuPG Made Easy) is a C language library that allows to 
+add support for cryptography to a program. It is designed to make 
+access to public key crypto engines like GnuPG or GpgSM easier for 
+applications. GPGME provides a high-level crypto API for encryption, 
+decryption, signing, signature verification and key management."
index d10b709322f906f7dfdaa8b765b9a267362eafce..10dba56ca29e18c1dcc4c54e516ed04b67ad2672 100644 (file)
@@ -1,6 +1,6 @@
 category: Libs
-requires: cygwin libgpg-error
-sdesc: "GnuPG cryptography support library (development)"
+requires: libgpgme-devel
+sdesc: "GnuPG cryptography support library (documentation)"
 ldesc: "GPGME  (GnuPG Made Easy) is a C language library that allows to 
 add support for cryptography to a program. It is designed to make 
 access to public key crypto engines like GnuPG or GpgSM easier for 
This page took 0.059345 seconds and 5 git commands to generate.