gnome/gtk2.0: enabled MIT-SHM and Xinerama support
authoryselkowitz <yselkowitz@e127d73d-b18e-4ae1-a744-a22e6a3ccd30>
Mon, 9 Feb 2009 03:46:29 +0000 (03:46 +0000)
committeryselkowitz <yselkowitz@e127d73d-b18e-4ae1-a744-a22e6a3ccd30>
Mon, 9 Feb 2009 03:46:29 +0000 (03:46 +0000)
git-svn-id: https://cygwin-ports.svn.sourceforge.net/svnroot/cygwin-ports/ports/trunk@5669 e127d73d-b18e-4ae1-a744-a22e6a3ccd30

README
gtk2.0-2.14.7-2.cygport [moved from gtk2.0-2.14.7-1.cygport with 98% similarity]
libgtk2.0-devel.hint
libgtk2.0_0.hint

diff --git a/README b/README
index 8900fc21ff5d5105b6471eb98d53eb57756f536b..89e019c64da5f75603d7339224da62366431e4ad 100644 (file)
--- a/README
+++ b/README
@@ -23,6 +23,7 @@ Runtime requirements:
   libXext6-1.0.4-1
   libXfixes3-4.0.3-2
   libXi6-1.1.3-2
+  libXinerama1-1.0.3-1
   libXrandr2-1.2.3-1
   libXrender1-0.9.4-2
   python
@@ -30,7 +31,7 @@ Runtime requirements:
 Build requirements:
 (besides corresponding devel packages)
   automake2.5-2.63-1
-  automake1.9-1.9.6-3
+  automake1.7-1.7.9-4
   binutils-20080624-2
   cygport-0.4.3-1
   gawk-3.1.6-1
@@ -1349,6 +1350,9 @@ Files included in the binary packages:
 
 Port Notes:
 
+----- version 2.14.7-2 -----
+Added support for MIT-SHM and Xinerama.
+
 ----- version 2.14.7-1 -----
 Version bump.
 
similarity index 98%
rename from gtk2.0-2.14.7-1.cygport
rename to gtk2.0-2.14.7-2.cygport
index 27ff6464d7ba3612744d0a24221ff18513f5a5bc..41f3b39eee1cfc028dc033fe7f24d8fb8f69ab88 100644 (file)
@@ -49,10 +49,8 @@ CYGCONF_ARGS="
        --disable-glibtest
        --enable-explicit-deps
        --enable-xkb
-       --disable-shm
        --disable-test-print-backend
        --disable-visibility
-       --disable-xinerama
        --with-gdktarget=x11
        --with-xinput
 "
index 3afd53ac4a14f2179fb2fbcdcad7ff7d5e005991..f6e13ad51bf4a03c0e33da0a24ab100f7c2f05d7 100644 (file)
@@ -1,5 +1,5 @@
 category: Gnome X11
-requires: cygwin libgtk2.0_0 libatk1.0-devel libcairo-devel libfontconfig-devel libgdk_pixbuf2.0-devel libglib2.0-devel gettext libpango1.0-devel libX11-devel libXcomposite-devel libXcursor-devel libXdamage-devel libXext-devel libXfixes-devel libXi-devel libXrandr-devel libXrender-devel python
+requires: cygwin libgtk2.0_0 libatk1.0-devel libcairo-devel libfontconfig-devel libgdk_pixbuf2.0-devel libglib2.0-devel gettext libpango1.0-devel libX11-devel libXcomposite-devel libXcursor-devel libXdamage-devel libXext-devel libXfixes-devel libXi-devel libXinerama-devel libXrandr-devel libXrender-devel python
 external-source: gtk2.0
 sdesc: "Multi-platform GUI toolkit (development)"
 ldesc: "Offering a complete set of widgets, GTK+ is suitable for 
index b725ecf634d61467d873321da51d054bc7f0282b..24f0558934b9a58f5c3063cc78971874e1c98ddb 100644 (file)
@@ -1,5 +1,5 @@
 category: Gnome X11
-requires: cygwin gnome-icon-theme libatk1.0_0 libcairo2 libfontconfig1 libgdk_pixbuf2.0_0 libglib2.0_0 libintl8 libpango1.0_0 libX11_6 libXcomposite1 libXcursor1 libXdamage1 libXext6 libXfixes3 libXi6 libXrandr2 libXrender1 shared-mime-info
+requires: cygwin gnome-icon-theme libatk1.0_0 libcairo2 libfontconfig1 libgdk_pixbuf2.0_0 libglib2.0_0 libintl8 libpango1.0_0 libX11_6 libXcomposite1 libXcursor1 libXdamage1 libXext6 libXfixes3 libXi6 libXinerama1 libXrandr2 libXrender1 shared-mime-info
 external-source: gtk2.0
 sdesc: "Multi-platform GUI toolkit (runtime)"
 ldesc: "Offering a complete set of widgets, GTK+ is suitable for 
This page took 0.025687 seconds and 5 git commands to generate.