libEMF-1.0.13-1
[git/cygwin-packages/libEMF.git] / libEMF.cygport
CommitLineData
661b96cc 1NAME="libEMF"
aac1915e 2VERSION=1.0.13
661b96cc
MA
3RELEASE=1
4CATEGORY="Graphics Libs"
5SUMMARY="A library for generating Enhanced Metafiles"
6DESCRIPTION="libEMF is a library for generating Enhanced Metafiles on systems which
7don't natively support the ECMA-234 Graphics Device Interface
8(GDI). The library is intended to be used as a driver for other
9graphics programs such as Grace or gnuplot. Therefore, it implements a
10very limited subset of the GDI."
11
12HOMEPAGE="http://libemf.sourceforge.net/"
13SRC_URI="mirror://sourceforge/libemf/libemf-${PV}.tar.gz"
aac1915e 14SRC_DIR="libemf-${PV}"
661b96cc
MA
15PATCH_URI="
16 libEMF-iconv.patch
17"
18
19abi=1
20PKG_NAMES="${PN} ${PN}${abi} ${PN}-devel"
21libEMF_SUMMARY="${SUMMARY} (utilities)"
22libEMF_CONTENTS="
23 --exclude=usr/share/doc/${PN}/html
24 usr/bin/*.exe
25 usr/share/doc/
26"
27libEMF1_SUMMARY="${SUMMARY} (runtime)"
28libEMF1_CONTENTS="
29 usr/bin/*-${abi}.dll
30"
31libEMF_devel_SUMMARY="${SUMMARY} (development)"
32libEMF_devel_CATEGORY="Devel ${CATEGORY}"
33libEMF_devel_REQUIRES="libiconv-devel"
34libEMF_devel_CONTENTS="
35 usr/include/
36 usr/lib/
37 usr/share/doc/${PN}/html/
38"
39
40
41KEEP_LA_FILES=none
aac1915e 42BUILD_REQUIRES="libiconv-devel"
661b96cc
MA
43
44CYGCONF_ARGS="--enable-editing"
45
46src_install() {
47 cd ${B}
48 cyginstall
49
50 dodir /usr/share/doc/${PN}
51 cp -r ${S}/doc/html ${D}/usr/share/doc/${PN}
52}
This page took 0.023487 seconds and 5 git commands to generate.