Convert to spec style
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>
Wed, 24 Jul 2013 23:17:23 +0000 (18:17 -0500)
committerYaakov Selkowitz <yselkowitz@users.sourceforge.net>
Wed, 24 Jul 2013 23:17:23 +0000 (18:17 -0500)
README [deleted file]
glade3-xfce4.hint [deleted file]
libxfcegui4-devel.hint [deleted file]
libxfcegui4.cygport [moved from libxfcegui4-4.10.0-1.cygport with 62% similarity]
libxfcegui4.hint [deleted file]
libxfcegui4_4.hint [deleted file]

diff --git a/README b/README
deleted file mode 100644 (file)
index cb8d308..0000000
--- a/README
+++ /dev/null
@@ -1,72 +0,0 @@
-libxfcegui4
-------------------------------------------
-Xfce4 GUI library
-
-Runtime requirements:
-  cygwin-1.7.5-1
-  libatk1.0_0-1.28.0-1
-  libgcc1-4.3.4-3
-  libgdk_pixbuf2.0_0-2.18.6-1
-  libglade2.0_0-2.6.4-1
-  libglib2.0_0-2.22.4-2
-  libgtk2.0_0-2.18.6-1
-  libICE6-1.0.6-1
-  libintl8-0.17-11
-  libpango1.0_0-1.26.2-1
-  libSM6-1.1.1-1
-  libstartup-notification1_0-0.10-1
-  libX11_6-1.3.3-1
-  libxfce4util4-4.6.2-1
-  libxfconf0_2-4.6.2-1
-(glade3-xfce4)
-  libgladeui1_9-3.6.7-1
-
-Build requirements:
-(besides corresponding -devel packages)
-  autoconf2.5-2.65-1
-  automake1.10-1.10.3-1
-  binutils-2.20.51-2
-  cygport-0.9.85-1
-  gawk-3.1.7-1
-  gcc4-core-4.3.4-3
-  libtool-2.2.7a-15
-  make-3.81-2
-  pkg-config-0.23b-10
-  xfce4-dev-tools-4.6.0-10
-
-Canonical website:
-  http://www.xfce.org/
-
-Canonical download:
-  http://www.xfce.org/archive/
-
--------------------------------------------
-
-Build instructions:
-  unpack libxfcegui4-4.6.4-X-src.tar.bz2
-    if you use setup to install this src package, it will be
-        unpacked under /usr/src automatically
-  cd /usr/src
-  cygport ./libxfcegui4-4.6.4-X.cygport all
-
-This will create:
-  /usr/src/glade3-xfce4-4.6.4-X.tar.bz2
-  /usr/src/libxfcegui4-4.6.4-X-src.tar.bz2
-  /usr/src/libxfcegui4-devel-4.6.4-X.tar.bz2
-  /usr/src/libxfcegui4_4-4.6.4-X.tar.bz2
-  /usr/src/libxfce4kbd-private-devel-4.6.4-X.tar.bz2
-  /usr/src/libxfce4kbd-private5-4.6.4-X.tar.bz2
-
--------------------------------------------
-
-Port Notes:
-
------ version 4.6.4-1 -----
-Version bump.
-
------ version 4.6.1-1 -----
-Initial release of Xfce 4.6 for Cygwin 1.7.
-
-
-Cygwin port maintained by:
-http://sourceware.org/cygwinports/
diff --git a/glade3-xfce4.hint b/glade3-xfce4.hint
deleted file mode 100644 (file)
index 7790349..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-category: Xfce Devel
-requires: glade3 libglib2.0_0 libgtk2.0_0 libxfcegui4_4
-external-source: libxfcegui4
-sdesc: "Glade-3 Xfce4 plugin"
-ldesc: "Xfce4 GUI library"
diff --git a/libxfcegui4-devel.hint b/libxfcegui4-devel.hint
deleted file mode 100644 (file)
index 3decd6b..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-category: Xfce
-requires: libxfcegui4_4 libgdk_pixbuf2.0-devel libglib2.0-devel libgtk2.0-devel libICE-devel libpango1.0-devel libSM-devel libX11-devel libxfce4util-devel
-external-source: libxfcegui4
-sdesc: "Xfce4 GUI library (development)"
-ldesc: "Xfce4 GUI library"
similarity index 62%
rename from libxfcegui4-4.10.0-1.cygport
rename to libxfcegui4.cygport
index fe8123b7944e9c089196e324c331dc56e3e59a65..a5faffcc26e93e8a16a202d65298eab3795b0d20 100644 (file)
@@ -1,8 +1,14 @@
 inherit xfce4
 
-DESCRIPTION="Xfce GUI library (DEPRECATED; new code should use libxfce4ui)"
+NAME="libxfcegui4"
+VERSION=4.10.0
+RELEASE=1
+CATEGORY="Libs"
+SUMMARY="Xfce GUI library (DEPRECATED)"
+DESCRIPTION="This is the previous Xfce GUI library for packages which have yet
+to be ported to libxfce4ui (new in 4.10)."
 
-PKG_NAMES="${PN}_4 ${PN}-devel"
+PKG_NAMES="${NAME}_4 ${NAME}-devel"
 libxfcegui4_4_CONTENTS="etc/postinstall/ usr/bin/cygxfcegui4-4.dll usr/lib/libglade/
                         usr/share/doc/ usr/share/icons/ usr/share/locale/"
 libxfcegui4_devel_CONTENTS="usr/include/xfce4/libxfcegui4/ usr/lib/libxfcegui4.*
diff --git a/libxfcegui4.hint b/libxfcegui4.hint
deleted file mode 100644 (file)
index d69c309..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-category: Xfce
-sdesc: "Xfce4 GUI library (sources)"
-ldesc: "Xfce4 GUI library"
diff --git a/libxfcegui4_4.hint b/libxfcegui4_4.hint
deleted file mode 100644 (file)
index f66d429..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-category: Xfce
-requires: libatk1.0_0 libgdk_pixbuf2.0_0 libglib2.0_0 libgtk2.0_0 libICE6 libintl8 libpango1.0_0 libSM6 libstartup-notification1_0 libX11_6 libxfce4util6
-external-source: libxfcegui4
-sdesc: "Xfce4 GUI library (runtime)"
-ldesc: "Xfce4 GUI library"
This page took 0.028984 seconds and 5 git commands to generate.