Fix for CVE-2011-3970
[git/cygwin-packages/libxslt.git] / libxslt-1.1.26-3.cygport
similarity index 87%
rename from libxslt-1.1.26-2.cygport
rename to libxslt-1.1.26-3.cygport
index 90857c9a0dcc3fd96d964bc406ffdb9315bb20a0..37e563e848c0f0ea9fac9fca20bb43a356250800 100644 (file)
@@ -6,7 +6,8 @@ SRC_URI="ftp://xmlsoft.org/libxml2/${P}.tar.gz"
 PATCH_URI="
        mirror://portage/dev-libs/${PN}/files/libxslt.m4-${PN}-1.1.26.patch
        mirror://portage/dev-libs/${PN}/files/${PN}-1.1.23-parallel-install.patch
-       1.1.26-no-undefined.patch
+       mirror://portage/dev-libs/${PN}/files/${PN}-1.1.26-undefined.patch
+       mirror://portage/dev-libs/${PN}/files/${PN}-1.1.26-pattern-out-of-bounds-read.patch
 "
 
 PKG_NAMES="${PN} ${PN}-devel ${PN}-doc python-${PN}"
@@ -38,3 +39,5 @@ src_install() {
 
        mv ${D}/usr/share/doc/libxslt-python-${PV} ${D}/usr/share/doc/python-libxslt
 }
+
+KEEP_LA_FILES="shared"
This page took 0.019609 seconds and 5 git commands to generate.