New syntax for IVMS prolog epilog size

Nick Clifton nickc@redhat.com
Thu Sep 10 08:11:00 GMT 2009


Hi Douglas,

> This is what rejected patch would have generated for prologue size. The 
> VMS Debugger expects the prologue size to be in these particular units 
> for whatever reason.
> 
>         data4.ua         (.LPE2-.LFB2)/16*3     // DW_AT_HP_prologue
> 
> I'll propose the following syntax, please comment and advise:
> 
>     data4.is    .LPE2-.LFB2  //DW_AT_HP_prologue

Why do you need the new syntax ?  Can't you just evaluate the expression 
in the assembler ?  [Checks gcc-patch archive ... ah, the problem is 
that the expression is not guaranteed to be consistent].

> Instead of "is", maybe "slot" or some other term?  Once the syntax is
> agreed upon I will submit a gas and new gcc patch.

A more descriptive name would be better.  Since the point of this 
directive is to insert the number of slots between two labels, how about:

   .slot_count  .LPE2 , .LFB2

Ie a using descriptive name and taking two arguments to show that the 
directive counts the number of slots between the two labels.

Is the slot count always guaranteed to be a 4-byte value or could it be 
bigger (8-byte maybe ?) or smaller.  If this is the case then adding a 
size to the directive would make sense.  Ie:

   .slot_count4  .LPE2 , .LFB2

Cheers
   Nick




More information about the Binutils mailing list