This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Setup.exe - snapshot runs but compiled from cvs get application error.

I downloaded snapshot 6 for setup (setup-2001-11-02-6.exe) from and 
like what I see - great job Robert and Chris.  Now my problem - I actually 
tried first to build the HEAD from cvs as well as the -rcategories and was 
getting an error in both cases.  I downloaded the snapshot and it works like a 
champ.  I then made sure I had all the current package updates and reconfigured 
and rebuilt my cvs version and I still get the error.

Now for the details.  When I try to run my built version (current cvs) it works 
fine when I select install from internet or install from local directory but 
when I select download from internet - setup crashes as soon as I select the 
next button and I get the following error:
setupcurr.exe - Application Error
The instruction at "0x0040f7cd" referenced memory at "0x00000001".  The memory 
could not be "read".

Click OK to terminate the program 
Click CANCEL to debug the program 

I also tried this with the version from -rcategories and get the same results 
but the snapshot works as it should.  I ran the program through gdb and traced 
the error to - max_len seems to end up as a -1 in the following lines:

char *native;
if (max_len == strlen (path))
  native = strdup (match->native);
  native = concat (match->native, "/", path + max_len, NULL);

it fails on the else portion of this routine.

Anyone got any suggestions how I can get my version compiling again - I know 
I'm a pain.  This is on a Win2000 laptop.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]