This is the mail archive of the cygwin-apps mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: just got wrong DLLs or wrong mutt.exe [attn mutt maintainer]

[Redirected to cygwin-apps]

On Feb 24 16:28, Christopher Faylor wrote:
> On Sat, Feb 24, 2007 at 01:55:33PM -0700, Eric Blake wrote:
> >According to Tom Hall on 2/24/2007 1:40 PM:
> >>I think there's a bug in the Cygwin setup
> >>
> >>The problem turned out to be that the version of mutt.exe I got was
> >>looking for /usr/bin/cygcrypto-0.9.7.dll and /usr/bin/cygssl-0.9.7.dll
> >>but setup.exe sent me /usr/bin/cygcrypto-0.9.8.dll and
> >>/usr/bin/cygssl-0.9.8.dll.  After copying the .7 versions from another
> >>machine, mutt seems to be working fine :-).
> >
> >Actually, it means that Corinna's statement that "None of the packages
> >in the Cygwin net distribution is built against openssl 0.9.7 anymore."
> >in is wrong.
> >The mutt maintainer needs to upload a new package in order to correct
> >this.  Meanwhile, I will let Corinna or the mutt maintainer decide if
> >the mutt setup.hint should be adjusted to point to openssl097
> >compatibility package instead of openssl.
> I'm in the process of generating a new mutt package now.

Ok, now the mutt package requires openssl097, which will work better for
setup, but that's not the solution.  Openssl 0.9.8 is part of the Cygwin
distro since July 2005.

I don't remember the history here, but for the mutt package I have two
maintainers in my list, Gary and cgf, cgf with a question mark.

Can anybody of you two please upload a new mutt version which links
against openssl 0.9.8?


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]