This is the mail archive of the cygwin-apps mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [HEADSUP] Moving setup sources to git

Corinna Vinschen writes:
> On Feb  9 22:48, Achim Gratz wrote:
>> At the time of writing an in-tree build configuration did not work for
>> me, although that later turned out to be an unrelated problem IIRC.  At
>> the moment I actually build in-tree since you can't configure both
>> architectures in an out-of-tree build anyway.
> This.  I don't understand.  Here's what I do:

Thanks.  I don't understand it either anymore because I just tried this
again (in a slightly different way because I build for 32bit on 32bit
and 64bit on 64bit) and it now works.  I'm not sure what went wrong the
first time I tried it, but it was telling me something about me needing
to reconfigure and throwing away the cache each time I built for the
other architecture.

>   $ bash -c "NOCONFIGURE=1 ./"

Very obvious now... but still too well hidden.

>   $ cat > <<EOF
>   #!/bin/bash
>   cpu=$(basename $PWD)
>   [ -n "$cpu" ] && \
>     ../setup/configure --host=$cpu-w64-mingw32 --target=$cpu-w64-mingw32
>   EOF

That's been bothering me for a while, the test for determining the build
and host type in just doesn't give the right results most
of the time and I always have to add the --host=<...> manually.  What (if
anything) is --target=<..> doing?

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Wavetables for the Waldorf Blofeld:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]