This is the mail archive of the cygwin-apps mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: are curr: and test: no longer accepted in .hint files?

> > What's the supported way now to tell calm which versions are previous,
> > current, and test when you need to override the defaults?
> I'm assuming you have a recent cygport, which is now generating 
> <pvr>.hint rather than setup.hint files.
> It's not helpful to mention specific versions in a <pvr>.hint files, so 
> curr: is not permitted, and test: is not permitted to specify a version
> If you need to override the default version ordering, then a separate 
> per-package override.hint [1] can be used.
> In this case, I think all you want to do is continue to mark 2.0.0-b9-1 
> as a 'test' version.  As discussed in [2], the current thinking is that 
> should be achieved with a 'test:' label in the associated pvr.hint, but 
> unfortunately, this package pre-dates the pvr.hint changes, so you'll 
> have to use override.hint
> [1]
> [2]

Thanks. I hadn't seen [1] yet. I'll rework the hint files.

Thanks to whoever overhauled the package maintainer's guide in the last
year or two. The last time I looked at it, it was badly out of date. What's
there now is good.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]