This is the mail archive of the
mailing list for the Cygwin project.
Re: noarching source packages
- From: Brian Inglis <Brian dot Inglis at SystematicSw dot ab dot ca>
- To: cygwin-apps at cygwin dot com
- Date: Fri, 5 May 2017 18:20:19 -0600
- Subject: Re: noarching source packages
- Authentication-results: sourceware.org; auth=none
- References: <firstname.lastname@example.org> <87wpa54u0a.fsf@Rainer.invalid> <email@example.com> <87lgqg73kr.fsf@Rainer.invalid>
- Reply-to: Brian dot Inglis at SystematicSw dot ab dot ca
On 2017-05-01 13:57, Achim Gratz wrote:
> Jon Turney writes:
>> What is your reason for changing the name?
> There shouldn't be two different naming conventions for the same
> purpose. So
> with purpose:=[source|debuginfo] would be preferrable.
>> I was wondering if we need to explicitly identify debuginfo
>> archives as a different kind of thing. Currently, debuginfo
>> packages work just like any other install archive, which is fine,
>> except for perhaps they need a separate filter in setup.
> They wouldn't with the above naming convention and you'd just tick
> another box to say you want them installed, just like sources. We
> might even skip the archful directories and just do
> [noarch|x86|x86_64] as well in the same place.
In the same vein, boxes for doc and devel packages, where available,
would make selection easier for users, developers, and maintainers,
but require changes to cygport and setup to integrate handling.
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada