This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Compiling EGCS: no luck

As I need a Fortran compiler I tried to compile egcs under b19.  I downloaded
egcs version 1.0.1. I didn't get it to work.  Here's what I tried (paraphrased 
from memory--no direct access to PC right now):

Build in source tree:
   unpack with tar
   cd egcs-1.0.1
This bombs at gcc/protoize.c where it wants to include sys/dir.h.  The
#include logic seems somewhat broken, needs to include dirent.h.  Fixed that.

Then it got further until the newly built xgcc can't find stdio.h etc.  I
changed my mount tables so they could be found in /usr/include.

Now it runs through until it want's to link g77.  It doesn't seem to link
anything else but g77.o, which of course leads to lots of undefined
externals.  I couldn't figure out how to fix that.  Looks like make is doing
strange things here but then the Makefiles are so complex I couldn't follow
them through.  Ok, so my attempt stops there.

Another try:
   read the install docs.  Say to (and I did)

   mkdir objdir
   cd objdir
This didn't get me anywhere.  The configure runs fine, creates all the
Makefiles and directories in objdir.  But make says after listing a few
lines from the Makefile:

   no rule to make target argv.c
So make doesn't find the source tree!  All the VPATH variables are set
correctly.  Seems to me make is somehow broken.  Another message on the list
suggested to remove the spaces around the = signs in the VPATH assignments
but it didn't help.  MAKE_MODE=unix too.

The same procedure starts ok on b18 (but bash crashes later on) and works
fine on Linux.

Any ideas?

For help on using this list (especially unsubscribing), send a message to
"" with one line of text: "help".

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]