This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

RE: foo: Permission denied

Earnie Boyd wrote:
> Michael Nagatkin wrote:
> >  I get a "foo: Permission denied" error when running a script that
> >  redirects to a file, "foo". I tried removing the file, but get the
> >  same error.
> Is foo really foo.exe?  Is this on a NTFS?

 No, foo is just simply foo - also, user has write permission
 in foo's directory and I tried experimenting with variations
 on umask (007, 777, etc).

 Yes, NTFS (win2000).

 Further, like the "problem with mmap and cygwin 1.1.8" post",
 when I run a strace I get

        "geterrno_from_win_error: windows error 5 == errno 13"

 This problem is evocative of many other "Permission denied"
 posts I have seen in the mail archives. I have followed
 recommendations regards mkpasswd and tried to make sense
 of the ntsec info. I have chmod problems as well.

 Wouldn't it be nice if windoze had a /tmp equivalent where
 read-write permissions were wide open? Testing for such a
 problem would be much simplified. Is there a way Cygwin could
 create a

        drwxrwxrwx   2 nobody          4096 Apr  1 12:34 tmp/

 as part of the install? If any of this is ridiculous, please
 flame me, I am a newbie and will take any education I can get.

Want to unsubscribe from this list?
Check out:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]