This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

RE: user name

The text below between dashed lines is what I saw going to the archive page
suggested by Jim.
But when I run "mkpasswd -d", I don't see any line with my username in there
Any suggestions..??


First, I'm on Win2k connected to an NT4 hosted domain. The userid I use to
log into windows is on the domain, not the local machine.

The cygwin setup program runs mkpasswd and mkgroup with the -l switch so it
only generates the local information.

It looks like id.exe (and probably login?) use the *name* you logged in with
as a key into /etc/passwd. If its not there it almost seems like it takes
the group ID and finds the first user in /etc/passwd with that group and
assumes you're that person. Or, I'm probably wrong.

Anways, I ran mkpasswd -d and grep'ed out the line with my user name and
appended that to /etc/passwd. Then cygwin got the right user ID and user
name, but the group was still messed up.

I then ran mkgroup -d and appended that to /etc/group. I'm not sure if it
was unique to our setup or what, but the local configuration had a group
with ID 513 and name None and our domain had a group with ID 513 and a
reasonable name. So I deleted the bogus looking entry from the local group
information (the one with the name "None").

After doing that id.exe returns the right user name, user id, group name and
group id and the shell environment variables get set to seemingly correct

I *don't* have ntsec set in CYGWIN - I assume that would invalidate most of
what I did, but haven't tried.

-----Original Message-----
From: []
Sent: Thursday, April 12, 2001 7:53 PM
To: Josh Sugnet
Subject: Re: user name

I had this same problem, your ID doesn't have a password.  
I found the solution by going to and doing a search for 
"user administrator".  On like the second page there was 
an entry entitled "RE why am I administrator" or something 
like that.  It had instructions on how to fix it.


On 12 Apr 2001, at 14:08, Josh Sugnet wrote:

> I recently installed the Cygwin toolset, and have a small question about
> names and user ids.  Say I have an account with username "joeuser" on the
> machine where I installed the tools.  This "joeuser" user has
> priviledges on that machine.  When I run the 'id' command after starting
> tools(bash) when logged into the win2k machine as  "joeuser", the output
> indicates that my username is "administrator", with a uid of 500.  Is
there any
> way to have my username in Cygwin match my username from the win2k
> environment?  This would be really handy for using ssh.
> thanks,
> josh
> --
> Want to unsubscribe from this list?
> Check out:

Want to unsubscribe from this list?
Check out:

Want to unsubscribe from this list?
Check out:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]