This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: dumper.exe doesn't work


Thursday, 19 April, 2001 Reinhard JESSICH wrote:

>> >>>i don't think so. maybe gdb snapshots are built without cygwin core
>> >>>dumps support? can you build gdb yourself and check? make sure that
>> >>>configure finds sys/procfs.h and win32_pstatus_t in it.
>>                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ only this, i think.
RJ> I have build gdb from source and I saw in the config.h file in the bfd subdirectory, that
RJ> HAVE_WIN32_PSTATUS_T is defined. Therefore, I think core dump support is build
RJ> in gdb per default. Sorry for making you trouble with this.


RJ> I have found in the list archive, that I have to do the following, to activate dumper.exe.
RJ> I have to add "error_start=drive:\\pathtodumper\\dumper.exe" to the CYGWIN
RJ> environment variable (I have tried unix path name and this doesn't work).

that's right. path should be native win32

RJ> The problem was, that this never terminated (maybe I have waited to less time,
RJ> only 2 Minutes). Then I have used gdb instead of dumper to check if cygnus exception
RJ> handler will call any program and this worked.

you can make dumper more "verbose":

set CYGWIN=error_start=drive:\\pathtodumper\\dump_wrapper.cmd

and create drive:\\pathtodumper\\dump_wrapper.cmd file containing one line:

============== dump_wrapper.cmd ====================
drive:\\pathtodumper\\dumper.exe -v -c %1 %2

for a testing purposes you can also dump any "healthy" process. just
get its win32-pid using 'ps -l' command, and then type

dumper -v <win32_pid_of_target_process>

RJ> Please can you tell me what I have done wrong here.

RJ> Then I have compiled my test program with the -mno_cygwin switch and installed
RJ> dumper instead of DrWatson in the registry as debugger.
RJ> This worked now and I got a coredump (.core), but this was not readable by gdb
RJ> (gdb --core=.core test.exe says unknown architecture).

ah, i remember something like this. but IIRC, message about unknown
architecture was only warning, and core loads successfully afterwards.

can you try to type
'info target' and 'info threads' and 'backtrace' in gdb?

i'll look if i can fix this warning, though.

Egor.   ICQ 5165414 FidoNet 2:5020/496.19

Want to unsubscribe from this list?
Check out:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]