This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: dumper.exe doesn't work


Friday, 20 April, 2001 Reinhard JESSICH wrote:

ed>> for a testing purposes you can also dump any "healthy" process. just
ed>> get its win32-pid using 'ps -l' command, and then type
ed>> dumper -d <win32_pid_of_target_process>
RJ> I have tried this and the complete bash shell died .

yes. it's win32 debugging api limitation. when debugger detaches from
debugee, debugee dies.

ed>> i'll look if i can fix this warning, though.
ed>> i've just checked the fix in. Check out dumper source and see if it helps.
RJ> Thank you, objdump says now:
RJ> dbz.exe.core:     file format elf32-i386
RJ> dbz.exe.core
RJ> architecture: i386, flags 0x00000000:
RJ> ....

RJ> But I get a message to stderr: no symbols.

RJ> If I call gdb with gdb --core=dbz.exe.core and I do 'info target', 'info threads'
RJ> and 'backtrace' and all worked. But I have not all symbols for the backtrace:
RJ> (gdb) backtrace
RJ> #0  0x77f782db in ?? ()
RJ> #1  0x77f04f37 in ?? ()
RJ> #2  0x6100bd88 in _size_of_stack_reserve__ ()
RJ> #3  0x6100c57c in _size_of_stack_reserve__ ()
RJ> #4  0x77fa7396 in ?? ()
RJ> #5  0x77f9926b in ?? ()
RJ> #6  0x77f86406 in ?? ()
RJ> #7  0x004010ca in main (argc=2, argv=0x1a020ca8) at dbz.c:16
RJ> #8  0x61003859 in _size_of_stack_reserve__ ()
RJ> #9  0x61003a3d in _size_of_stack_reserve__ ()
RJ> #10 0x61003a7c in _size_of_stack_reserve__ ()
RJ> #11 0x0040111f in cygwin_crt0 ()
RJ> I am sure I have compiled it with -g.

you got symbols only for those modules that were compiled so.
you compiled dbz.c w/ debug info, so you see function name and line
number in frame #7. All other frames belong to other modules -- to
cygwin1.dll (addresses 0x610xxxxx) and to windows system dlls
(addresses 0x77fxxxxx). To see symbols there, you should build those
modules w/ debug info too (possible for cygwin1.dll, impossible for
system dlls)

RJ> If I call gdb with gdb --core=dbz.exe.core dbz.exe I get a message from gdb:
RJ> core file may not match specified exec-file.
RJ> Is there something missing in the dumper or gdb implementation?
RJ> Is symbol writing not implemented in dumper?

symbols are not written to core dump to save space. they're taken from
program and dlls when gdb loads dump.

Egor.   ICQ 5165414 FidoNet 2:5020/496.19

Want to unsubscribe from this list?
Check out:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]