This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Am set up for debugging... what next.

On Mon, Apr 23, 2001 at 05:55:49PM -0600, Troy Noble wrote:
>Egor Duda said:
>    "... place known-working copy of cygwin1.dll and normal unmodified
>     copy of gdb.exe into x:\path\to\special\gdb\".
>So which is the right approach?

This is *a* right approach.

>I first tried with the current distribution copy of gdb.exe as well as
>the current cygwin1-1.1.8-2.dll into this alternate directory I
>created, but I always get the "memory 0x00000004 could not be read"
>thing that you get when you have two incompatible DLLs.

>Then I tried to build another DLL off the same sources as the
>debug-enabled DLL, this time without the --enable-debugging, and the
>generated .dll file was still 4.7MB.  Am now trying with
>--enable-debugging=no to see if I can get that to build a DLL with no
>debug symbols.

This does not build a DLL with no debugging symbols.  It builds a version
of cygwin with extra debugging information as in more *code* in the DLL.
Look for the '#ifdef DEBUGGING' sprinkled throughout the cygwin sources.

There is no need for you to avoid building a cygwin1.dll with symbols.

>From your description, it sounds like you are unable to even use the
gdb that you copied to its own directory.  You should be able to use
it to debug programs, e.g.  gdb -nw foo.exe .

However, you'll probably only be able to run it in non-gui mode, i.e.,
"gdb -nw".  You'll have to add the -nw to your gdb wrapper.


Want to unsubscribe from this list?
Check out:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]