This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Symbol link trouble ?

On Wed, Apr 25, 2001 at 12:40:40PM +0200, Pierre Muller wrote:
> >Aaargh! Really? I don't have any 95 for testing purposes so
> >I can't look for this. Did you ever think about upgrading to
> >OSR2, 98, ME, NT, W2K? Ok, ok, seriously, if you can't live
> OS version is 4.00.950 B
>    B means OSR 2, no ?

I think so.

> >with that, you should set your CYGWIN environment variable to
> >contain "nowinsymlinks". In that case, the old symlink method
> >is used again.
>   Adding nowinsymlinks to CYGWIN env variable does
> indeed cure the problem !
>    I also find this bug quite strange:
> the wrong destination to the symbolic link is
> kept even if cygwin DLL is unloaded from memory
> (at least Taskinfo does not see this file as open anymore !)
> Where can this information be kept then ???

Could be a buffering technique of W95. I have just read the Microsoft
KB article Q128932 "How Windows 95 Resolves Shortcut Links" but it
doesn't obtain any additional information.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                      
Red Hat, Inc.

Want to unsubscribe from this list?
Check out:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]