This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

sftp->ls creates sftp-server.exe.stackdump


I have successfully setup openssh (openssh-2.9p2-3.tar.bz2) on my nt4sp6a
system. Logging on and scp works quite fine. However I am not able to get
sftp to work. I installed sshd as service using cygrunsrv:
$ cygrunsrv.exe -I sshd -p /usr/sbin/sshd -a '-d -d -d' -d 'Cygwin SSHD' -e
GWIN=ntsec' -1 /tmp/sshd.out -2 /tmp/sshd.err

Furthermore /etc/sshd_config is setup to run sftp:
#Uncomment if you want to enable sftp
Subsystem      sftp    /usr/sbin/sftp-server

Now when I run sftp -vvv hartmann@localhost everything works fine. I get
authenticated and logged in. However when I run "ls"
sftp-server.exe.stackdump (attached) is created and the client is locked. I
can only press CTRL-C in order to get back to the shell.
------------------------------------------------- sftp session:
sftp> put /tmp/sshd.out .
debug3: Looking up /tmp/sshd.out
debug3: Sent message fd 6 T:17 I:2
debug3: Received stat reply T:105 I:2
Uploading /tmp/sshd.out to /home/hartmann/./sshd.out
debug3: Sent message SSH2_FXP_OPEN I:3 P:/home/hartmann/./sshd.out
debug3: Sent message SSH2_FXP_CLOSE I:4
debug3: SSH2_FXP_STATUS 0
sftp> ls
debug3: Sending SSH2_FXP_READDIR I:6
debug3: Received reply T:104 I:6
debug3: Received 7 SSH2_FXP_NAME responses
drwxrwxrwx    3 hartmann Kein         4096 Aug  15:28 .
drwxrwxrwx    3 hartmann Kein            0 Jul  17:32 ..
-rw-------    1 hartmann Kein         2069 Aug  08:46 .bash_history
drwx------    2 hartmann Kein         4096 Aug  05:52 .ssh
-rw-------    1 hartmann Kein          687 Aug  15:26 .viminfo
-rwxrwxrwx    1 hartmann Kein         1060 Aug  15:18
-rw-r--r--    1 hartmann Kein            0 Aug  15:28 sshd.out
debug3: Sending SSH2_FXP_READDIR I:7
Killed by signal 2.
debug1: Calling cleanup 0x415b0c(0x0)
debug1: Calling cleanup 0x4190c8(0x0)
---------------------------------------------------- sshd.err log
subsystem request for sftp
debug1: subsystem: exec() /usr/sbin/sftp-server
debug1: fd 8 setting O_NONBLOCK
debug1: fd 7 setting O_NONBLOCK
debug2: callback done
Connection closed by remote host.
Closing connection to



Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]