This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Building rxvt?

On Wednesday 8 Aug 01, Seth Delackner writes:
> Has anyone successfully built rxvt from the sources at ?

On Thursday 8 Aug 01, David Starks-Browning writes:
> Shouldn't you be using the sources (optionally) distributed with the
> Cygwin version?  Anything at <> may be
> out of date.  (At least, that's what it says...)

So I grabbed the cygwin source (which appears to be identical) and tried building via './configure; make' which failed with:

   gcc -DHAVE_CONFIG_H -DDEBUG_STRICT  -c    -I. -I.. -I.  -O  command.c
   In file included from command.c:48:
   rxvt.h:99: X11/Intrinsic.h: No such file or directory
   rxvt.h:100: X11/cursorfont.h: No such file or directory
   rxvt.h:101: X11/keysym.h: No such file or directory
   In file included from command.c:50:
   command.h:54: X11/keysym.h: No such file or directory
   command.h:55: X11/keysymdef.h: No such file or directory
   make[1]: *** [command.o] Error 1

So I tried the configure settings mentioned in the cygwin patch readme:

./configure --x-includes="../W11 -IW11" \            
        --x-libraries="../W11/lib -mwindows ../W11/wrap/rxvt_res.o -Wl,--subsystem,console" \         
        --with-xpm-includes=../W11 \
        --with-xpm-library=../W11/lib \
        --enable-menubar \

Which causes make to fail on:
   gcc  -o rxvt command.o    main.o menubar.o misc.o netdisp.o screen.o scrollbar.o  xdefaults.o xpm.o  -L../W11/lib -mwindows ../W11/wrap/rxvt_res.o -Wl,--subsystem,console -L../W11/lib -lXpm -lX11  
   xpm.o(.text+0xcdd):xpm.c: undefined reference to `_imp__XpmReadFileToPixmap'
   collect2: ld returned 1 exit status

So what should I be doing differently?

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]