This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: problem with cron and network shares

At 12:00 PM 8/23/2001, Cioffari, Joseph wrote:
>I am currently able to execute the following command at the command line in
>cygwin with no problem:
>$cp /home/Administrator/test.doc J:/docs/sfrank   (Copies the file from my
>local cygwin home directory to a mapped network share)
>However, when I put this (or any cp/ftp/mv command that involves a network
>share) in my crontab it spits back an error saying "Permission Denied" when
>trying to copy the file over to the mapped network share.  It seems that
>cron will only copy files to my local machine directories but not network
>Just wondering why it works if I manually perform the operation but doesn't
>work ("Permission Denied") when I run it through cron.  I've also tried
>removing the file first just to make sure it wasn't copying over itself.
>Any ideas?

Does the user that cron run as have access to these shares?

Possible (easy) solution:  Use UNC paths instead.

Larry Hall                    
RFK Partners, Inc.            
118 Washington Street                   (508) 893-9779 - RFK Office
Holliston, MA 01746                     (508) 893-9889 - FAX

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]