This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

resize command hangs from ssh session

I've searched the archive and can't seem to find anything
applicable.  My problem:

Win2000SP2 CYGWIN_NT-5.0 1.3.6(0.47/3/2) 2001-12-08 17:02 i686 unknown
OpenSSH_3.0.2p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f

Open a Cygwin command shell (my default is configured to 80x45)
ssh to a RH Linux 7.1 box
Change the window size to, say, 80x60
Run the 'resize' command (on linux host)

The text cursor jumps to the bottom-right corner of the window
(this is normal) and just stays there (this is not normal).
resize never returns.  This behavior ALWAYS happens even if
I don't physically resize the window (i.e. run resize
immediately after logging in and it still hangs).

I've tried setting TERM=ansi, TERM=vt100 and TERM=cygwin
in the Linux shell with identical results.

If I logout (back to cygwin shell) and re-ssh from
the resized (80x60) window everything works and the
COLUMNS and LINES environment variables are correctly set.

As I understand it, resize sends a specific terminal control
sequence that requests the hardware to reply with the current
size.  I assume that either cygwin's bash isn't playing just
right, or something gets garbled over ssh.

As a side note, I tried running resize locally (in the
cygwin bash shell) and it fails looking for cygncurses5.dll,
which is not in any of my bin directories.  I did find
cygncurses6.dll in /usr/bin.  Is this related or just a

Suggestions on how to debug this further?

James Garrison                                Athens Group, Inc.                    5608 Parkcrest Dr                    Austin, TX 78731
PGP: RSA=0x92E90A3B DH/DSS=0x498D331C         (512) 345-0600 x150

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]