This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Resource leak in CYGWIN or /bin/sh?


I've been using CYGWIN for about a year with excellent results for some times, when
it stopped working. My systems are varying, typically Windows98SE with something from
128MB to 512MB of memory, with a fixed virtual memory of roughly 512MB. The latest
test I tried was a full install yesterday, so the system is up-to-date.

Around autumn 2001, after an update of CYGWIN, it became impossible for me to run
configure (let's say, for ImageMagick), because CYGWIN would run out of resources
even on a 512 MB computer and report

"fork_copy: user/cygwin data pass 2 failed, 0x980000..0xD59000, done 0, WIN32 error

At that time, cygwin has usually consumed almost all memory. Even after the process
finishes, resource consumption is so high that sometimes I can't even open a new
CYGWIN window (strangely enough, all normal Windows programs tell me that there is
still plenty of memory available... Maybe there's another resource that has been used
up?). The error message is varying, as is typical for low-resources (I believe), also
a random "Signal 11" is possible (which I saw reported here several times).
Reinstalling Cygwin doesn't make a difference, I get the same error message back. My
feeling is that either CYGWINs main process or one of the shells has a huge leak, of
what, I don't know. As I said, the problem was introduced some time in autumn last
year, so I'm sure that it's not a problem of configure, and yes, the problem comes up
with other programs as well, but are not that easy to reproduce. The
"configure"-Process of ImageMagick is *sure* to fail on my systems on all my CYGWINs

Any comments? Or at least: What lack of resources might stop my system from opening
any MS-DOS window? Normal Windows-Applications are fine! I realize that something
like this has been discussed several times, but I'm just unable to accept the answer
"add in more memory" or "reinstall" - I've been doing both.

I've been investigating this for quite some time, but I don't have the slightest clue
what's going on here.


Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]