This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: System API problem

Well, you post this again. Do you think that
if you post numerous times you'll force someone
on the list to answer your question ? Better
launch a debugger and find the source of your problem.

FYI - this was reported a while back (2 times i think).
As far as I remember no one else on the list was able
to reproduce the situation so no one was able to find the
solution. Maybe this means that something specific on your
system causes the error to show up. Try to find out what
and then report back. Also an output of "cygcheck -r -s -v"
would be useful.

The last thread that discussed this problem was started by
David Mathog and we did some private comunication with him
while I was trying to gather more information on his system
and asked him to perform some tests. I tried to debug this
on my system but with no succes - this error does not happen
on my system. The thread sybject is "system() function doesnt work 
outside cygwin". You can look at it in the maling list archive.
You may also wish to contact David and try to find out what is
the common thing on your systems - this may help find the problem.

Bandla Srinivas wrote:

> Hi,
>   I am using cygwin 1.3.6 to compile the unix sources,
> and use those executables on Win NT. I am getting
> Strange error when running my application.
>   I am using system API inside my application to
> execute commands. This is Sample Test program
> test.cpp:
>  main()
> {
> int status=system("diff t1.tct t2.txt");
> cout<<staus;
> }
> I compiled this in cygwin. I got test.exe. When i run
> test.exe from msdos prompt, it is printing 127. That
> means system api is returning error code as 127 it is
> equivalent to (ERROR_PROC_NOT_FOUND).
>  I copied cygwin1.dll to c:\winnt\system32.  system
> API has been defined in this cygwin1.dll. when i run
> this executable from dosprompt why it is not able to
> locate procedure system eventhough cygwin1.dll in
> path. Anybody faced such problem.  i have tried with
> different commands with in the system API. Same error
> code 127. What is the problem. can i have any solution
> for this problem.

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]