This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

FW: Updated: rxvt-2.7.2-8

Speaking from personal experience, I know the DELETE key (not the backspace)
has never worked quite right for me under a plain-vanilla cygwin install,
inside of bash. I'm not talking about inside of rxvt, but simply in the
plain old default command line interface (e.g. the thingy that the Cygwin
desktop shortcut runs).

Instead of erasing the character to the right of the cursor (as would happen
in any other windows app), I see an extra character inserted into my command
line. I think it's "~", but I can't remember for sure right now. This is
under Win2k pro, and also WinXP pro.

The backspace key on the other hand has always worked just fine.

All this to say - is there any way the behavior of the delete key could be
corrected in a default, plain jane install, to function properly?

(If this has already been discussed and fixed, then I apologize... It's been
a couple months since I actually performed a brand new install...)


From: Steve O <>

rxvt-2.7.2-8 has been uploaded to the Cygwin net distribution.
rxvt is a lightweight xterm that can display to either X or
native Windows. 

- Corrected backspace handling.
  This may cause some unexpected behavior if you have something like
     stty erase ^H 
  in your profile.  Either removing the stty line or changing it to
     stty erase ^?
  may fix the behavior.

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]