This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: FW: Updated: rxvt-2.7.2-8

At 04:41 PM 1/31/2002, Kevin Roth wrote:
>Speaking from personal experience, I know the DELETE key (not the backspace)
>has never worked quite right for me under a plain-vanilla cygwin install,
>inside of bash. I'm not talking about inside of rxvt, but simply in the
>plain old default command line interface (e.g. the thingy that the Cygwin
>desktop shortcut runs).
>Instead of erasing the character to the right of the cursor (as would happen
>in any other windows app), I see an extra character inserted into my command
>line. I think it's "~", but I can't remember for sure right now. This is
>under Win2k pro, and also WinXP pro.
>The backspace key on the other hand has always worked just fine.
>All this to say - is there any way the behavior of the delete key could be
>corrected in a default, plain jane install, to function properly?
>(If this has already been discussed and fixed, then I apologize... It's been
>a couple months since I actually performed a brand new install...)

The DELETE key in bash under the cmd.exe works just fine for me (i.e. 
just as it does in cmd.exe itself and just as you described it for 
cmd.exe)  This is on W2K and I tried Cygwin 1.3.6 and 1.1.6.  Worked in
either case for me.

Larry Hall                    
RFK Partners, Inc.            
838 Washington Street                   (508) 893-9779 - RFK Office
Holliston, MA 01746                     (508) 893-9889 - FAX

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]