This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Cannot SSH in to server

> Hard to say.  Try investigating the login shell vs. non-login shell bit.

I tried running bash --login from windows cmd and I could still log in. I
agree though, it appears that xterm, when launched from within X, is doing
something with bash. For example, rxvt from within X works just fine.

> Try reproducing this outside of an xterm (e.g., in bash command window).

When I do this I can get in. Likewise when I run from any xterm launched
from startxwin.bat. The problem is that I can't get in when I create xterms
after X has launched.

> Try disabling X-forwarding (by unsetting DISPLAY or running "ssh -x").

Tried both of these, still doesn't work.

> Try specifying the protocol explicitly ("ssh -1" or "ssh -2")...  I would

Tried these too, neither worked.

> also kill ssh agent for now, just to be sure.  Let us know which of these
> work and which don't.

Also no luck.

> Igor
> P.S. <pedantic>Also please check that you *are* running a *Cygwin* version
> of ssh</pedantic> ;-)

Yup, using OpenSSH_3.6.1p1, SSH protocols 1.5/2.0, OpenSSL 0x0090702f,
downloaded from cygwin's setup.exe.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]