This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Possible problem with ctags

[posted and mailed to Simon Liddington <>]

Robert Mecklenburg <> wrote in 

> I'm getting a strange error when I run ctags:
>   5 osaka:cimsoft$ /bin/ctags -e --recurse> 
>  ctags: cannot open temporary file : No such file or directo> ry
>  [Exi> t 1]
> If I run this under strace I get:


> My conclusion: Maybe the most recent release of ctags has a
> compiled-in default directory of .../liddins/... and that this
> directory is used if the TMPDIR environment variable is otherwise
> undefined.
> Comments?

I can confirm this discovery.  In fact, that is why I just started up 
news, to report the problem.  It is present with this version:

Exuberant Ctags 5.5, Copyright (C) 1996-2003 Darren Hiebert
  Compiled: Apr 14 2003, 10:16:41
  Addresses: <>,
  Optional compiled features: +wildcards, +regex, +internal-sort

(By the way, although this version announces itself as 5.5, it is really 
5.5.3 according to /setup.exe.)

The full compiled-in directory it is trying to use, as found by both 
FileMon and strings, is:


The obvious workaround is "export TMPDIR=$TMP"

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]