This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [ANNOUNCE] LibXSLT (1.0.27) test packages available

Hi Elfyn,

unfortunately I'm less fortunate with the new libxslt package than Andreas. I cannot translate a simple xml document to html with the new version of xsltproc. Here are some infos:

$ xsltproc -version
Using libxml 20507, libxslt 10027 and libexslt 718
xsltproc was compiled against libxml 20507, libxslt 10027 and libexslt 718
libxslt 10027 was compiled against libxml 20507
libexslt 718 was compiled against libxml 20507

$ xsltproc -catalogs /usr/local/lib/xml/stylesheets/docbook-xsl/html/docbook.xsl Tester2.xml > Tester2.html
runtime error: file /usr/local/lib/xml/stylesheets/docbook-xsl/html/html-rtf.xsl line 101 element apply-templates
xsl:apply-templates : can't find doc
no result for Tester2.xml

here's the Tester2.xml document:
<?xml version="1.0" standalone='no'?>
<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"

<article class="specification" lang="en" vendor="Fillmore Labs" revision="0.4"> <!-- revision of template -->

<section id="objectives">
The following chapters describe the required functionality of release 1.

With the old version of xsltproc Tester2.xml translates fine. I'm using the 1.52.1 XSL stylesheets. I tried the 1.61.2 XSL stylesheets as well and got the same result :o(

Do you know what's going wrong? Please let me know if you need more infos from my side.


-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]