This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: ssh connection closed

Elfyn McBratney wrote:

On Thu, 5 Jun 2003, Jonathan Hudgins wrote:

I am running sshd per instructions from /usr/doc/Cygwin/openssh-3.6.1p1-2.README.
I choose no privilege speration at setup time
I have also set the following values in sshd_config:

    PasswordAuthentication yes
    RhostsAuthentication no
    RhostsRSAAuthentication no
    RSAAuthentication no

When I login via ssh I don't get asked for a password (I think
this is ok because I ran ssh-user-config).  My problem is
that I get kicked out immediately after logging in.  I used to be
able to login fine (even with the setgid failure as below); but now
I can't.  Something changed (don't ask me I've tried a lot of
different iterations).

How do I diagnose this problem further?
/var/log/sshd.log has not been modified for a long time
Is a solution apparent from the given info?

$ ssh -v localhost
OpenSSH_3.6.1p1, SSH protocols 1.5/2.0, OpenSSL 0x0090702f
debug1: Reading configuration data /etc/ssh_config
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: Connecting to localhost [] port 22.
debug1: Connection established.
debug1: identity file /cygdrive/c/.ssh/identity type 0
debug1: identity file /cygdrive/c/.ssh/id_rsa type 1
debug1: identity file /cygdrive/c/.ssh/id_dsa type 2
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.6.1p1
debug1: match: OpenSSH_3.6.1p1 pat OpenSSH*
Last login: Thu Jun 5 07:13:15 2003 from
You are successfully logged in to this server!!!
setgid: Invalid argument


Is your /etc/group file out of sync? Does

$ mkgroup -l (or -d for domains) >/etc/group

Fix it?

Connection to localhost closed.

$ mkgroup -d >> /etc/group
solves the problem. I had already tried "mkgroup -l > /etc/group" per instructions from another posting, but I really needed the domain group.

Thank you,

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]