This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

rsh and rsync

I have downloaded cygwin today.

Doing rsync from Windows 2000 (running cygwin) to NetBSD Unix box with
the following:

rsync -av "test.txt" root@myunixServer:/sd0/rsync

I got the following error:
Runs commands on remote hosts running the RSH service.

RSH host [-l username] [-n] command

  host            Specifies the remote host on which to run command.
  -l username     Specifies the user name to use on the remote host. If
                  omitted, the logged on user name is used.
  -n              Redirects the input of RSH to NULL.
  command         Specifies the command to run.

rsync: read error: Connection reset by peer
rsync error: error in rsync protocol data stream (code 12) at

The rshd is running on NetBSD, .rhosts is setup and I tried "rsh" standalone
and run fine. Looked like the rsh usage is 

'RSH host [-l username] [-n] command'

but the "rsh" in rsync expected a different format.
On Unix boxes, it is:

rsh [-nd] [-l login] [login@]host [command]

What's wrong with this picture?

BTW, when specified "ssh" as the shell, rsync worked fine.

$ rsync --version
rsync  version 2.5.6  protocol version 26
Copyright (C) 1996-2002 by Andrew Tridgell and others
Capabilities: 32-bit files, socketpairs, hard links, symlinks, batchfiles,
              no IPv6, 32-bit system inums, 64-bit internal inums

rsync comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
are welcome to redistribute it under certain conditions.  See the GNU
General Public Licence for details.

Thanks for your help


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]