This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Problem Running Apache through Cygwin


Thanks for the reply.  Well you're right about apache and cygwin's conflict.
I can't install in as a service either.  I tried, "cygrunsrv -I httpd -p
/usr/sbin/httpd -a -k".  That worked fine, but when I "cygrunsrv -S httpd"
it gives me this:
cygrunsrv: Error starting a service: QueryServiceStatus:  Win32 error 1062:
The service has not been started.
Kind of strange :)  I am running XP and I checked the Event Log, it shows an
error with httpd, but doesn't give any relevant information.

"The description for Event ID ( 0 ) in Source ( httpd ) cannot be found. The
local computer may not have the necessary registry information or message
DLL files to display messages from a remote computer. You may be able to use
the /AUXSOURCE= flag to retrieve this description; see Help and Support for
details. The following information is part of the event: httpd : PID 3364 :
starting service `httpd' failed: execv: 1, Operation not permitted."

Well I will be playing with this to see if I can get something to work.  If
not I will wait until the Cygwin 1.5.0 update :)

Sergio Parracho

> -----Original Message-----
> From: []On Behalf
> Of Elfyn McBratney
> Sent: Friday, June 13, 2003 4:36 PM
> To: Sergio
> Cc:
> Subject: Re: Problem Running Apache through Cygwin
> On Fri, 13 Jun 2003, Sergio wrote:
> > Hello,
> >
> > I have the latest cygwin build, I downloaded it off the net a
> week ago. This
> > is my first install of Apache.  I think I have done everything correctly
> > regarding configuration, yet I still can't view documents
> through apache.  I
> > have set the ServerName to and port to 80.  The error
> log shows
> > the following:
> >
> > [...]
> > I am running Apache via /usr/sbin/apachectl start
> >
> > It gives me the following response
> >
> > /usr/sbin/apachectl start: httpd started
> >
> > But still I can not connect to
> >
> > Very strange problem.  Any help GREATRLY appreciated!
> Sergio,
> Apache is kinda broken at the moment until Cygwin 1.5.0 is
> released (not too far
> away). If your on NT (4.0/2000/XP) you should be able to get up
> and running with
> cygrunsrv (see /usr/doc/Cygwin/apache-1.3.24-5.README) but I
> doubt it'll be for
> long.
> Elfyn
> --
> Elfyn McBratney (
> Systems Administrator
> /
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]