This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Problem Running Apache through Cygwin

On Sat, 14 Jun 2003, Sergio wrote:

> Elfyn,
> Thanks for the reply.  Well you're right about apache and cygwin's conflict.
> I can't install in as a service either.  I tried, "cygrunsrv -I httpd -p
> /usr/sbin/httpd -a -k".  That worked fine, but when I "cygrunsrv -S httpd"
> it gives me this:
> cygrunsrv: Error starting a service: QueryServiceStatus:  Win32 error 1062:
> The service has not been started.
> Kind of strange :)  I am running XP and I checked the Event Log, it shows an
> error with httpd, but doesn't give any relevant information.
> "The description for Event ID ( 0 ) in Source ( httpd ) cannot be found. The
> local computer may not have the necessary registry information or message
> DLL files to display messages from a remote computer. You may be able to use
> the /AUXSOURCE= flag to retrieve this description; see Help and Support for
> details. The following information is part of the event: httpd : PID 3364 :
> starting service `httpd' failed: execv: 1, Operation not permitted."
> Well I will be playing with this to see if I can get something to work.  If
> not I will wait until the Cygwin 1.5.0 update :)

Did you try /var/log/httpd.log ?

(Damn I'm up way toooooo early :0)

Elfyn McBratney (
Systems Administrator /

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]