This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Fwd: Re: CygWin adding CRs, hurting CVS client/server communications?

Understood. I've compiled CVS from source on my server (which is how I tracked down and confirmed the CRLF issue), but am not set up to compile anything on the Windows client. I doubt I'll have time in the near future to try, so for now I'll have to ditch CVS/SSH, and once I truly need version control again, either see if it's working again or go with a commercial solution. No big deal for now...thanks for trying though.


At 01:55 PM 6/28/2003, Charles Wilson wrote:
Sorry, guys, but I can't reproduce this.


openssh              3.6.1p1-2
cvs                  1.11.5-1
cygwin               1.3.22-1

:pserver: and :ext:(CVS_RSH=ssh) mode, with server

Server is running:
Concurrent Versions System (CVS) 1.11.1p1 (client/server)
(with local hacks)
OpenSSH_3.4p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f

Because I can't reproduce this, somebody who is experiencing the problem is going to have to track it down and provide a detailed (e.g. "this code right here: "..." is wrong...) bug analysis.

I can't fix what I can't see.

cvs maintainer wrote:
Forgot to CC this to the list.

Date: Sat, 28 Jun 2003 10:37:51 -0600
To: "Van Rooyen G-J <>" <>
Subject: Re: CygWin adding CRs, hurting CVS client/server communications?

I've seen the same symptoms...output is garbled because CRs are left in the strings CVS interprets, and it spits them out after concatenating you wind up with lines like "textCRtextNL"...I've dumped the output and confirmed that this is what is happening.

Another good point...I am using the CygWin CVS client, not WinCVS.


At 06:49 AM 6/28/2003, you wrote:

I have exactly the same problem as Toscani describes. Last week I did a routine update on my Cygwin packages, and my Cygwin CVS client (which worked fine the previous day) could not authenticate with the server any more. The "login" command works fine, but any subsequent operations fail to authenticate. Furthermore, the server error message is garbled, as if a CR/LF problem occurred.

Client: Cygwin on WinXP

Server: Redhat (not sure of the version)

Authentication: Plain pserver, no SSH.

Judging from Patrick's response (who uses WinCVS, and not Cygwin CVS) the problem lies somewhere in the Cygwin CVS client, not in Cygwin SSH.


--- in response to: ---

Works like a charm here, both for binmode and textmode mounts.
My system: Win2k, WinCVS and Cygwin SSH
The problem mentioned in your mailing list reference was fixed long time ago.
Do your line endings change as well if you scp a textfile from your client to your server? If yes, then we have indeed an ssh issue on WinXP platforms. Otherwise your problem must lie somewhere else.


--- in response to: ---

Hey folx...currently using OpenSSH under CygWin on an XP box to communicate with a CVS server on a Linux box. Recently upgraded my CygWin installation (1.3.22(0.78/3/2), including OpenSSH to v3.6.1p1 (the latest available under CygWin), and now CVS client/server communications over SSH (CVS_RSH=ssh) don't work.
I've tracked the problem deep enough to suspect that SOMETHING in CygWin converts LF to CR+LF line terminators across SSH. This pretty much hoses CVS client/server communications, as the CVS server interprets all incoming lines as byte strings including a CR at the end (it treats LF as the actual terminator)...especially bad for pathname interpretation, but lots of other things may be affected as well. I've tried altering the CVS server code to eat the extra CRs, but too many other things break (including file data exchange I'd bet...can't tell which CRs are valid data and which are inserted by the system) for that to be effective.
Found a reference in the mailing list archives to a similar problem someone was having last October, but the solution was to install a snapshot from that time period which seems to be no longer available. I'm wondering if the fix for this issue never found its way into more recent versions of the CygWin system components? I've upgraded CVS on both client and server, but based on my testing, I don't think CVS itself is adding the CRs...please flame if I'm wrong on that one. <g> Not sure what else to do right now but do without version control for a bit...any better ideas?
- Toscani

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]