This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: bash.exe: *** Couldn't reserve space for cygwin's heap

Thanks, Jason, for your help.

Unfortunately, rebaseall gives me the same problem:

$ rebaseall
m.AllocationBase 0x0, m.BaseAddress 0x61560000, m.RegionSize 0x210000,
m.State 0
F:\root\bin\bash.exe: *** Couldn't reserve space for cygwin's heap
(0x61560000 <
0xA00000>) in child, Win32 error 0

I cannot execute bash (since I get the cygwin heap error) to run rebaseall
so I ran it under sh, but still get a heap error:(  Am I doing something
wrong?  Thanks for any other suggestions you might have!


"Jason Tishler" <> wrote in message">
> Kimberlie,
> On Thu, Dec 18, 2003 at 07:23:36PM -0500, Kimberlie S wrote:
> > I tried using rebase (suggested by Jason Tishler  in his email dated
> > Tue, 02 Dec 2003) but just get an error message saying that bash is
> > not rebaseable.
> Assuming this is a rebase problem, then you need to rebase your system
> (i.e., "all" of your Cygwin DLLs) not bash.
> > Any other suggestions?
> Use rebaseall instead of rebase *and* read the rebase README:
> Jason
> -- 
> PGP/GPG Key: or key servers
> Fingerprint: 7A73 1405 7F2B E669 C19D  8784 1AFD E4CC ECF4 8EF6

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]